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About this course
Objectives of the course
Upon completion of this course you will be able to:
- Create 2D Layout views in a 3D environment
- Export 2D geometry to a 3D environment
- Create drawings from 2D Layout views

Targeted audience
Mechanical Designers

Prerequisites
Students attending this course should be familiar with CATIA V5 
Fundamentals.

1 day
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Introduction: 2D Layout for 3D Design
You will become familiar with the 2D Layout for 3D Design workbench and interface.



Student Notes:

2D Layout for 3D Design
����������	��

Copyright DASSAULT SYSTEMES 5

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
T

E
M

E
S

Introduction to 2D Layout for 3D Design Workbench

2D Layout for 3D Design workbench has the following benefits:

A tool to create specifications
2D preliminary geometry (parts only)
Dimensioning, tolerancing, annotations, dress-up

2D Layout of 3D design
Drafting-like sheets and views
Transparent background and visualization filters for each view
Advanced print management
Drawing creation from 2D Layout

Concurrent 2D & 3D
Generation of 3D geometry from 2D geometry
In editing context with transparent display of 3D

Generative Drafting can still be used for deliverables
Generation of initial design information (geometry, dimension, dress-up, etc.)
Creation of view types not available into 2D to 3D design (breakout, broken, detail, etc.)
Generation of geometry exact & normalized (fillets, etc.)
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General Process

The general process of designing a part using the 2D Layout for 3D Design 
workbench is given below:

1 Define 2D Layout 
sheets

2 Create 2D Views 

Export 2D Geometry3

4
Complete design in 
GSD / Part Design 
workbench



Student Notes:

2D Layout for 3D Design
����������	��

Copyright DASSAULT SYSTEMES 7

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
T

E
M

E
S

Accessing the 2D Layout for 3D Design Workbench

Click Start > Mechanical Design > 2D Layout for 3D Design.

Click OK

Select the layout 
format and the 
standard to be 
used
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User Interface 

3D window

3D features

2D features
2D transparent
views

The working document is a CATPart with a dedicated 2D Window in addition to 
the usual 3D window.

2D window
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User Interface: Tools (1/2)

Icon/ 
Option

Name of the 
Tool/Option

Description

Invisible

Standard

Hides both the 2D background (i.e. the 3D representation of 2D 
elements which do not belong to the current view, but to other 
views) and the 3D background (i.e. the representation of all 3D 
elements, including edges, faces and 3D wireframe)

Shows both the 2D and the 3D background.

Unpickable Prevents from selecting all elements in both the 2D and the 3D 
backgrounds, even though you can see them. You can just handle 
2D elements.

Low intensified Applies a low intensity light for all elements in both the 2D and 
the 3D backgrounds.

Unpickable low-
intensified

Introduces a low light for all elements in both the 2D and the 3D 
backgrounds. Additionally, although you can see these elements, 
you cannot select them. You can just handle 2D elements in the 
current view.

New View Creates a projection view in an existing layout.

New 
Section/Auxiliary 

view
Creates a section view, a section cut or an auxiliary view.

A list of some commonly used tools in the 2D Layout for 3D Design workbench are 
listed in the table shown below:
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User Interface: Tools (2/2)

Icon/ 
Option

Name of the 
Tool/Option

Description

New Section 
From 2 Planes

New View From

Creates two aligned section views or aligned section cuts using 
two existing 3D planes as supports.

Creates a view from an existing view, or from a 3D plane.

3D Profile Creates a profile feature on the view support plane, and create a 
profile feature on a plane parallel to the view support plane.

3D Plane Creates a 3D plane feature.
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User Settings (1/2)

Before working with the 2D layout for 3D design, activate the following options.

In the Visualization toolbar, make sure that the ‘Sketcher 
Grid’ and the ‘Cutting Plane’ icons are inactive. 

Also in the same Visualization toolbar, make sure that 
‘Display Backgrounds as Specified for Each View’, ‘Show 
Constraints’ and ‘Analysis Display Mode’ icons are active. 

In the Tools toolbar, ensure that the Create Detected 
Constraints icon is active. You can configure the other 
icons as required.

To create associative geometry in case of use-edge, 
activate the ‘Create associative use-edges’ option from the 
Tools > Options > Mechanical Design > 2D Layout for 3D 
Design > Geometry.
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User Settings (2/2)

Activate the ‘Create driving 
dimension’ option from the Tools > 
Options > Drafting tab.

Activate the ‘Keep link with 
selected object’ option from the 
Tools > Options > Infrastructure > 
Part Infrastructure > General tab.
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Setting the Standards

You can set the drafting standards by accessing Tools > Standards > Drafting. You can 
select the 3D standard you want to use in order to configure it (position of the 2D views 
into the 3D one, etc.)
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2D Layout Creation
In this lesson, you will learn to create 2D Layout views and add 2D Geometry in these 
views.

Initiating the 2D layout
Creating 2D Geometry in the Views
Analyzing the Profile
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Initiating the 2D Layout
You will see how to initiate a 2D Layout and start creating 2D Views in the 3D 
environment.
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Creating Projection Views

Create the required views using the ‘New View’
icon. The view type depends on it’s position 
relative to the front view.

Click the New View icon. The Compass appears 
in the 2D Layout window. Simultaneously in the 
3D window a view box appears.

Projections views are created from the 2D window both in the 2D and the 3D window.

1 Create a new layout selecting the standard

2

3 Using the Compass in the 2D window the view 
can be changed. Position the created view to the 
required location and validate it by clicking in 
the 2D Layout window. The front view is created.

4

1

Compass View Box

24
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Setting Sheet Parameters 

Before creating 2D Views, it is essential to set the Sheet parameters and choose an 
appropriate scale, projection angle and sheet size.

Edit the Sheet format 
(optional)

Set the Sheet Scale

1

3

Define the Projection Method
2

1

2

3
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Creating Additional Views using 2D View Elements

Click the New Section/Auxiliary View icon.

Select the option in the Tools Palette toolbar.

Move the view to its position and click to 
validate its creation.

Create the 2D geometry in the view using the 
interactive drafting tools.

Select in the 2D view a line which defines the 
support plane of the view.

You will see how to create Auxiliary and Section views using 2D view elements.

1

2

3

4

5

2

3

4

1
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Creating Additional Views using 3D View Elements

Click the Section 
From 2 Planes icon

Select two 
planes in the 
3D window

Move the view to its 
position and click to 
validate its creation

Create the 2D geometry in the 
view using the interactive 

drafting tools

Click the Create 
New View From 

icon

Select a 
plane in the 
3D window

Move the view to its 
position and click to 
validate its creation

Create the 2D geometry 
in the view using the 

interactive drafting tools

1 2 3 4

1 2 3 4
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Creating 2D Geometry in the Views
You will learn to create 2D Geometry in the 2D Layout Views. 
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You will see how to create 2D Geometry into the projection views. Associativity 
between the views can be created using formulas linking the dimensions together.

Creating 2D Geometry in the Projection Views

Create the 2D geometry in the front view 
using the interactive drafting tools

Activate an other view to be completed. Display 
using the contextual menu on the front view the 
folding lines 

Complete the other projection views 
using the folding lines

2

3

1

3

2
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3D Visualization and Use Edge Capabilities

Click the Display Backgrounds as Specified 
for Each View icon

The 3D part is 
displayed in the 
2D Layout, for 
the purpose of 
edge extraction.

Extract, using the ‘Use Edge’ toolbar, 
the 3D features you need to complete 
the profile.

You can visualize the 3D background in the 2D Layout and 
extract features from 3D to 2D using the ‘Use Edge’ tools.

1

2 1

To use the edges from 3D, set ‘Create 
associative use-edge’ option on, in the Tools > 
Option > Mechanical Design > 2D Layout for 
3D Design > Geometry tab.
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Managing the Background Visualization (1/2)

Go to Tools > Layout view filters Create or edit an existing filter.

Filter Edition for each 2D background 
views or 3D background bodies (i.e.
Hide         YES/NO
No Pick    YES/NO
Low Int YES/NO)

You will see how to set and manage Layout filters.

1 2
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Managing the Background Visualization (2/2)

Right-click the selected view and access 
the properties.

Select the visualization filter. 

Select the background visualization mode.

3

4

5

3

4
5
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Customizing Cutting Plane and Display Background Options

You can activate ‘Display when loading 
layout’ option from Tools > Options > 
Mechanical Design > 2D Layout for 3D 
Design > Visualization.

The ‘Cutting Plane’ and ‘Display 
Background as Specified for Each View’
icons will be highlighted in the 
Visualization toolbar, when the Layout is 
loaded.

This option helps you to visualize the 3D 
Background and cut the section along the 
Cutting Plane. This option is activated by 
default.

You will learn, how to customize Cutting Plane and Display Background Options
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Customizing 2D Visualization Mode (1/2)

To customize this option, go to Tools > 
Options > Mechanical Design > 2D 
Layout for 3D Design > View Creation 
and ‘Activate 2D visualization mode’.

The option can also be set from the 
contextual menu of the view. Right-click 
the View, go to Properties > Visualization 
and activate ‘Activate 2D visualization 
mode’.

You will learn, how to Customize 2D Visualization Mode 
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Customizing 2D Visualization Mode (2/2)

Deactivating the option, the 
solid part is displayed in 
the background.

Activating the option, only 
the 2D Planar elements are 
displayed. 



Student Notes:

2D Layout for 3D Design
����������	��

Copyright DASSAULT SYSTEMES 28

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
T

E
M

E
S

Exporting the 2D View to 2D layout

Open the CATDrawing containing 
the 2D view to export

Tools > Export Layout view

Select layout sheet in which you want to export 
the CATDrawing view

Select the element types you 
want to export

It is possible to export CATDrawing views in 2D layout view

1

3

2

4
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Using 2D Components

2D components to be 
instantiated

To speed up the view design, you can use the 2D component mechanism.

Create detail sheets and 
instantiate 2D components from 
the 2D layout CATPart

Instantiate 2D components from 
the 2D component catalogs

1

2



Student Notes:

2D Layout for 3D Design
����������	��

Copyright DASSAULT SYSTEMES 30

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
T

E
M

E
S

Back Clipping Capabilities

Right-click the selected view, and go to 
Clipping > Activate Clipping Frame, from the 
contextual menu.

Define the frame or select the plane to define 
the clipping.

Clipping can be deactivated by right-clicking 
on the clipped view and by selecting the 
“Deactivate Clipping Frame” function from the 
contextual menu.

A frame or a plane can be used for clipping the 3D part in a 2D layout view.

1

2

3

1

2

3
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Creating Clipping Views

Circular Clip View

Right-click the View, and go to Clipping > Clip View
from the contextual menu.

1

Select the Circle from Tools Palette that appears
on the screen.2

Create a circle in the view, where you want to keep the 
3D Background as a Circular Clip.

3

4

1

34

A circular or a polygonal profile can be used for clipping the 3D part in a 2D layout 
view.

A clipping view can be unclipped by right-clicking on 
the clipped view and by selecting the ‘Unclip View’
function from the contextual menu.
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Dress-up Creation

2D layout to 3D Design product facilitates the designers by providing standard 
dimensions, annotations and dress-up capabilities. This is an important added-value 
as compared to the Sketcher. 

Dress-up capabilities similar to those in the drafting workbench are available.
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Analyzing the Profile
You will see how to analyze a profile for its constraint status.
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Sketch Analysis

For Sketch Analysis, go to Tools > Sketch Analysis. Or you 
can also access the tool from the ‘Tools’ toolbar.

This tool can be used to determine a profile’s constraint 
status (i.e., Under-constrained, Iso-constrained, Over-
constrained, or Inconsistent), and where degrees of 
freedom still exist in the profile. 

The Sketch Analysis tool can also be used to determine if a 
profile is open or closed. This is useful if you receive an 
error when trying to create profile-based features.

To solve problems with profiles, the ‘Sketch Analysis’ tool can be used.

Sketch Analysis

Unresolved profile
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Sketch Analysis Window (1/3)

The sketch analysis window has three tabs. Each tab contains information to 
help analyze the profile.

The Geometry tab is used to determine if the sketch geometry is valid:

A. The ‘General Status’ area 
analyzes several elements in 
the context of the entire 
sketch.

B. The ‘Detailed Information’
area provides a status and 
comment on each geometric 
element in the sketch.

C. The ‘Corrective Actions’
area lets you correct 
geometry. You can:

a. Convert an element 
into a construction 
element.

b. Close an open profile.
c. Erase unwanted 

geometry.
d. Hide all constraints.
e. Hide all construction 

geometry.

A

B

C

a

b c d

e
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Sketch Analysis Window (2/3)

The Projections/Intersections tab is used to determine the status of all projected 
elements:

A. The ‘Detailed Information’
area provides a status and 
comment on each projected 
or intersected element in the 
sketch.

B. The ‘Corrective Action’ area 
lets you correct geometry. 
You can:

a. Isolate geometry.
b. Activate or Deactivate 

a constraint.
c. Erase geometry.
d. Replace 3D geometry.
e. Hide all constraints.
f. Hide all construction 

geometry.

A

B

a

b c d e

f
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Sketch Analysis Window (3/3)

The Diagnostics tab displays a full diagnosis of all sketched geometry. It provides 
an analysis of the sketch as well as information on individual geometrical elements:

A. The ‘Solving Status’ area 
provides an overall analysis of 
the sketched geometry.

B. The ‘Detailed Information’ area 
provides a description and 
status on each constraint and 
geometric element in the 
sketch. 

C. The ‘Action’ area enables you 
to:

a. Hide all constraints.
b. Hide all construction 

geometry.

C

B

A

a b
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Performing a Quick Geometry Diagnosis (1/2)

Use the following steps to analyze a sketch:

Activate the View, containing 
the profile to be analyzed.

Select the Sketch Solving 
Status icon.

The Sketch Solving Status 
window appears. It indicates 
the overall status of the Sketch 
Geometry. In this case, the 
sketch is under-constrained, 
even though the sketch 
appears to be all green (iso-
constrained). 

Under-constrained and over-
constrained geometrical 
elements are highlighted on 
the profile.

2

3

1

2

3

Sketch Solving Status

4

4



Student Notes:

2D Layout for 3D Design
����������	��

Copyright DASSAULT SYSTEMES 39

C
op

yr
ig

ht
 D

A
S

S
A

U
LT

 S
Y

S
T

E
M

E
S

Performing a Quick Geometry Diagnosis (2/2)

Use the following steps to analyze a sketch 
(continued):

Select the Sketch Analysis icon in the Sketch 
Solving Status window or in the Tools toolbar.

The Sketch Analysis window appears. In this 
example, the profile needs to be closed and the 
point needs to be changed to a construction 
element.

Select Close to close the Sketch Analysis 
window.

4

5

6

4

5

6
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Using the 2D Layout Geometry
In this lesson, you will learn to create 3D geometry from the 2D Views.

Creating 3D Geometry from 2D Layout
Exporting the 2D Layout
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Creating 3D Geometry from 2D Layout
You will learn to export the 2D geometry to create 3D geometry.
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Create 3D Geometry from 2D Geometry (1/2)

Click the 3D Profile icon

Select in the active view a element 
belonging to the profile you want to extract

A 2D profile which can be 
used to define Pad, 
pocket, etc. is created In 
the 3D window

Create profile features

You will see how to use 2D geometrical information to define 3D features.

Define the profile using the Profile 
Definition dialog box

1

2

3

2

3
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Create 3D Geometry from 2D Geometry (2/2)

Click the 3D Plane icon

Click a line in a 2D view

A plane is created
In the 3D window

Create planes

After creating planes and profile feature, the corresponding 3D features can be designed.

1
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Links Between 3D Geometry and 2D Layout (1/2)

The 2D Layout views can also be created using geometry of existing parts. An 
associative link exists between the parent and driven parts.

In the example shown, a coincidence constraint is 
applied between the highlighted edge and the 
projected edge of the shaft.

The changes in the original part are 
propagated to the 2D Layout.

You have to locally update the 2D Layout views 
to drive the changes in the destination part.

You can create the associative link by 
activating the ‘Create associative use-edges’
option from Tools > Options > Mechanical 
Design > 2D Layout for 3D Design > Geometry 
tab.
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The Specification tree shows ‘View Updation 
Required’ symbol, since the shaft height is 
modified.

After Updation, the changes in the height 
of the shaft are reflected in the 2D Layout.

Links Between 3D Geometry and 2D Layout (2/2)

If the ‘Create associative use-edges’
option is deactivated, the use–edge 
will be non-associative with respect to 
the part.
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Exporting the 2D Layout
You will learn how to extract the output from 2D Layout and 3D Design workbench.
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Print Capabilities (1/2)

Activate the 2D or the 3D window 
to be printed by double-clicking

Select “File > Print”

In the Print window, set the 
various options for print

You will see how to set print area and options for printing.
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Print Capabilities (2/2)

Through the contextual menu/properties of the sheet, it is possible to set the 
print options.
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Create a Drawing from 2D Layout

The created drawing can be completed 
using the generative drafting capabilities

Select at this step a format
compatible with the one used in the 2D 
Layout for 3D design workbench

Go to Start > Mechanical Design > 
Drafting workbench.

A CATDrawing can be extracted automatically from the 2D to 3D 
CATPart document.
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