Weld Design

CATIA V5 Training
Foil
About this course

Objectives of the course
Upon completion of this course you will be able to:
- Weld parts,
- Generate Weld reports,
- Extract 2D views from 3D welds.

Targeted audience
Mechanical and Structural Designers

Prerequisites
Students attending this course should be familiar with CATIA V5 Fundamentals.
# Table of Contents (1/2)

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbench Presentation</td>
<td>5</td>
</tr>
<tr>
<td>Accessing the Workbench</td>
<td>6</td>
</tr>
<tr>
<td>Weld Information in the Specification Tree</td>
<td>7</td>
</tr>
<tr>
<td>User Interface: Toolbars</td>
<td>8</td>
</tr>
<tr>
<td>Where is Weld Design used?</td>
<td>9</td>
</tr>
<tr>
<td>Why should we use the Weld Design Workbench?</td>
<td>10</td>
</tr>
<tr>
<td>Welds Creation</td>
<td>12</td>
</tr>
<tr>
<td>Classification of Welds</td>
<td>13</td>
</tr>
<tr>
<td>Welds definition inputs</td>
<td>14</td>
</tr>
<tr>
<td>How to Create a Fillet Weld</td>
<td>16</td>
</tr>
<tr>
<td>How to Create a Square Butt Weld</td>
<td>17</td>
</tr>
<tr>
<td>How to Create a V Butt Weld</td>
<td>18</td>
</tr>
<tr>
<td>How to Create Bevel Butt Weld</td>
<td>19</td>
</tr>
<tr>
<td>How to Create a V Butt Weld with Broad Root Face</td>
<td>20</td>
</tr>
<tr>
<td>How to Create a Bevel Butt Weld With Broad Root Face</td>
<td>21</td>
</tr>
<tr>
<td>How to Create a J Butt Weld</td>
<td>22</td>
</tr>
<tr>
<td>User Weld</td>
<td>23</td>
</tr>
<tr>
<td>How to Create a User Weld</td>
<td>24</td>
</tr>
</tbody>
</table>
## Table of Contents (2/2)

- Symmetric Welds 25
- Weld Creation Mode 26
- How to Use 'Without Preparation Mode' 27
- Options in the Weld Creation Dialog Box 28

### Weld Reports and Drawings

- Weld Report Generation 32
- Drawing Generation 34
- 3D to 2D Weld Annotations 35
- Inserting Weld Reports in Drawings 36

### Master Exercise: Table

- Table: Step 1 37
- Table: Step 2 39
- Table: Step 3 40

---

**Instructor Notes:**
Workbench Presentation

You will be introduced to terminologies and tools specific to ‘Weld Design’ workbench.
Accessing the Workbench

You can access the Weld Design Workbench:
- From the Start Menu
- Using the ‘Workbench Command’

To be able to access the workbench using the Workbench Command, the ‘Weld Design’ workbench should be included in the list of favorite workbenches.

Instructor Notes:
Weld Information in the Specification Tree

On Creation of a weld, its information is stored in the specification tree as shown in the image below.

A Joint is a set of two or more components whose geometry is used for creating welds. A Joint Body is a set of welds. A Joint body is attached to a joint. While creating a weld, you can specify the Joint Body under which you want to put your weld.

Instructor Notes:
User Interface: Toolbars

Apart from the ‘Welds’ and ‘Joints’ toolbar, the ‘Constraints’, ‘Move’ and ‘Annotations’ toolbars from Assembly Design workbench are also useful while working in Weld Design Workbench. These toolbars are also available in ‘Weld Design’ workbench.

Weld Creation Mode
Fillet Weld
Square Butt Weld
Single V Butt Weld
Single Bevel Butt Weld

\{ Welds with broad root face. \}
Single U Butt Weld
Single J Butt Weld
Use Weld

Joint
Joint Body
Instructor Notes:
Where is Weld Design used?

Weld Design has wide industrial applications in structural and mechanical engineering designs.

It is used in:
- Fabricated Metal Products.
- Transport Equipments:
  - Truck and Bus bodies
  - Car Bodies
  - Aerospace Jigs
- Industrial Machinery
- Industrial Equipments
- Mobile Equipments

Instructor Notes:
Why should we use the Weld Design Workbench? (1/2)

Deploying Weld Design Workbench has several advantages:

- The creation of the weld in the 3D digital Mock-Up will allow designer to manage digital pre-assembly, mass inertia, space reservation and drafting annotation.
- The parts to be welded get prepared automatically after creating the weld thus creating associative assembly features in addition to the physical weld element.
- Weld Plates get automatically created as per the parameters used to define the weld.
- Welds are integrated within 3D Design. Mass and the inertia of the weld ribbons are added to the mass and the inertia of the whole assembly so that User, specifying the weld material, can perform relevant calculation. Welds can also be integrated in the clash collision of the assembly and other structural and stress analysis.
Why should we use the Weld Design Workbench? (2/2)

- Welds can be fully integrated with drafting. Welds are automatically generated in the standard views, section views and section cuts and are impacted by the Hidden Line Removal visualization mode of the assembly. 2D Welds annotations are also automatically created.
Welds Creation

You will learn to create different types of welds.
Classification of Welds

Welds are basically classified into two types:

- Fillet weld
- Butt weld

Fillet Welds are the welds which do not require any preparation before the creation of weld. Preparation means removal of material from the weld plates so as to accommodate the weld bead in it.

Fillet weld: Does not require any preparation.

Butt Weld: Requires preparation of weld plates

The 'Butt Welds' require the plates to be prepared to accommodate the weld bead.
Welds Definition Inputs (1/2)

Main Characteristics: The weld shape depends upon the 'Characteristics' that you select.

Trimming limits: If you do not want the full edge to be welded, you can specify the trimming limits.
Welds Definition Inputs (2/2)

Geometric Inputs: The geometric inputs depend upon the type of weld you are creating. For example: A fillet weld requires two surfaces and V Butt weld requires four surfaces as the geometric inputs.

You can also use the ‘Selection Assistant’ which helps you select the geometric inputs in a sequence.
How to Create a Fillet Weld

1. Click the Fillet Weld tool.
2. Select the faces as shown.
3. Enter Weld Height = 3mm. Re-limit the weld if required.
4. Click OK to the weld creation dialog box.
5. Fillet is created and stored in an Assembly Joint. Annotation is automatically created.

Instructor Notes:
How to Create a Square Butt Weld

1. Click the Square Butt Weld tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges or four faces as geometric inputs for the weld.
4. Enter Weld Width = 4 mm and click OK to the weld creation dialog box.
5. The weld is created and stored in an Assembly Joint.

The Preparation which is created corresponds to a remove operation.

Instructor Notes:
How to create a V Butt Weld

1. Click the V Butt Weld tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges or four faces as geometric inputs for the weld.
4. Enter Weld Width, Angle and Height as 2.0mm, 45deg and 1.0mm respectively and click OK.
5. The weld is created and stored in an Assembly Joint.

Instructor Notes:
How to create Bevel Butt Weld

1. Click the Bevel Butt Weld tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges or three faces as geometric inputs for the weld.
4. Enter Weld Width, Angle and Height as 2.0mm, 15deg and 1.0mm respectively.
5. Select Propagation mode as “Without Propagation” and click OK.
6. The weld is created and stored in an Assembly Joint.

Instructor Notes:

The Preparation which is created corresponds to a remove operation.
How to Create a V Butt Weld with Broad Root Face

1. Click the V Butt Weld With Broad Root Face tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges or four faces as geometric inputs for the weld.
4. Enter Weld Width, Angle and Height as 2.0mm, 15deg and 1.0mm respectively.
5. Select Propagation mode as “Without Propagation” and click OK.
6. The weld is created and stored in an Assembly Joint.

Instructor Notes:
How to Create a Bevel Butt Weld With Broad Root Face

1. Click the Single-Bevel Butt Weld With Broad Root Face tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges or three faces as geometric inputs for the weld.
4. Enter Weld Width, Angle and Height as 2.0mm, 15deg and 1.0mm respectively.
5. Select Propagation mode as “With Propagation” and click OK.
6. The weld is created and stored in an Assembly Joint.

Instructor Notes:
How to Create a J Butt Weld

1. Click the Single- J Butt Weld tool.
2. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.
3. Select two edges (Select the edge of Base first) or three faces as geometric inputs for the weld.
4. Enter Width = 2mm, Angle = 10deg, Height = 3mm.
5. Select Propagation mode as “With Propagation” and click OK
6. The weld is created and stored in an Assembly Joint.

The Preparation which is created corresponds to a remove operation.

Instructor Notes:
User Weld

A user weld is created using a predefined shape as the ‘Weld bead’. The inputs for user weld are:

- A ‘Part Body’ in which the weld bead is designed.
- An ‘Assembly Remove Feature’ containing the information of the remove operation between the ‘Weld Bead’ part and the parts to be welded.
- The Annotation associated to your weld.

Instructor Notes:
How to Create a User Weld

In this example, the required inputs for the user weld are already created for you.

1. Click the User Weld tool.
2. Enter a weld name.
3. Select the Solid Body 'WeldBead' from Weld.1 part as the Weld Bead.
4. Select 'Base' and 'Handle' as the welded Parts.
5. Select 'Assembly Remove.1' as the 'Associated Assembly Feature'
6. Select 'Weld Symbol.1' as the annotation for the weld and click OK.

You can also remove the weld bead part from bill of materials using the option shown above.
Symmetric Welds

You can also create symmetric welds using the ‘Double Weld’ tools available for Fillet, V-Groove, U, Bevel, Half-V and J-Groove welds.

In symmetric welds, as the name suggests both the weld seams share the same parameters.

Instructor Notes:
Weld Creation Mode

There are two weld creation modes available. The ‘Default’ mode and ‘Without Preparation Mode’

In the ‘Default mode’, the weld plates need not be already cut to accommodate the weld bead. This mode requires geometrical inputs and parameters specifying the dimensions of the weld.

Whereas in the ‘Without Preparation Mode’, you have to simply select the faces holding the weld bead. These faces can created by removing material from the weld plates. An example is shown ahead.

Instructor Notes:
How to Use ‘Without Preparation Mode’

Before using the ‘Without Preparation Mode’, you have to make slots in the weld plates to accommodate the weld bead. In this example, the weld plates have been already created for you.

1. Change the ‘Default’ mode to ‘Without Preparation Mode’

2. Click the ‘Single V Butt weld’ tool.

3. Check the ‘Selection Assistant’ option to open the ‘Assistant Viewer’.

Select the faces as shown in the ‘Assistant Viewer’ and click OK.

The weld gets created in the prepared slot.

Instructor Notes:
Options in the Weld Creation Dialog Box

In this lesson, you will learn the use of various options in the Weld Creation Dialog box.

Instructor Notes:
Tangent Propagation Option

For the fillet weld, you can use the ‘Tangent Propagation’ option to extend the weld to the adjacent tangent edges.

To use this option, you have to select the geometric elements from the dialog box and click the ‘Propagation’ button.

Instructor Notes:
Preparation Mode Option

For welds which need preparation, two types of preparation modes are available.

The 'Without Propagation' option, removes the material from the welded part only at the portion of the weld whereas the 'With Propagation' option extends such removal of material throughout the edge of the welded part as shown above.

Instructor Notes:
Other Useful Options

In the ‘Type’ tab of the Weld Creation panel, you can select the weld to be ‘Simple’ or ‘Dashed’. The results of both the options are shown above.

In the ‘Annotation’ tab, you can use the ‘Weld Symbol’ and ‘Length Always displayed’ options to display the weld symbol and length as shown.
Weld reports and Drawings
You will learn to generate weld reports and drawings from 3D welds.
Weld Report Generation

You can generate a Weld Report using the 'Weld Report' command from the 'Analyze' menu.

This report can also be exported to a text or excel file using the 'Save As' button.
Drawing Generation

The welds are visible in the drawing views. To generate drawings:

- Switch to the 'Drafting' workbench.
- Generate standard views.

Welds are visible in each view. You can also create a section view using any one of the commands in the 'Sections' toolbar.

Instructor Notes:
3D to 2D Weld Annotations

You can also transfer the 3D weld annotations into your drawings using the ‘View From 3D Tool. This tool is present in the menu ‘Insert > View > Projections’

1. Click on View from 3D icon

2. From the specification tree, select the Annotation View containing the weld information.

The drawing will be updated with the weld information.

Instructor Notes:
Inserting Weld Reports in Drawings

You can insert the ‘Weld Report’ in the drawings using the ‘Insert Object’ command.

1. In the CATProduct, generate and save the weld report as an excel file.

2. In the CATDrawing, from the menu select ‘Insert > Object’.

3. In the ‘Insert Object’ panel, select the ‘Create from File’ option and select the ‘Weld Report’ excel file.

4. Select the ‘Link’ option to maintain associativity and click OK.

The weld report will be inserted in the drawing.
Table

Master Exercise Presentation

60 min

In this exercise you will create the Weld Joints for a Table.

To do so, you will have to:

- Create different types of welds depending upon the structure of the Table.
- Generate Weld Drawings from the 3D Welds
- Generate Weld Reports
Table: Step 1

Creating Welds

40 min

In this step you will:
- Insert a supporting bar for the Table
- Position the Bar and join it using Weld Features
- Modify the positions of the welded parts and check the welds.

Instructor Notes:
## Table: Step 2

**Generating Drawings**

15 min

In this step you will:
- Create Drawings using the Drafting Workbench.
- Include weld annotations in the drawings.

---

**Instructor Notes:**
Table: Step 3

Generating Weld Reports

5 min

In this step you will:
- Generate a Weld
- Export the Weld Report to an Excel File.

Instructor Notes:
Summary

In this course you have learned to:

- Create Welds in an assembly context.
- Use various options available in the 'Weld Creation' dialog box.
- Generate and analyze weld reports.
- Generate drawings and include weld representation and annotations in them.